fbpx
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: Using "Space Bar" to playback clips in browser

Using "Space Bar" to playback clips in browser 22 Aug 2017 17:14 #90052

  • bsquard
  • bsquard's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 11
  • Thank you received: 0
One annoying trait about the latest version of FXPx is a behavior in the browser. In the past, if you highlighted a clip and hit the space bar, the clip would begin to play back. Now (10.3.4) when you highlight a clip and hit space bar, a drop down appears under Video Roles column.

I can't figure out how to navigate to the clip from the Video Role column. Any ideas?

Thanks,

Blake

Please Log in or Create an account to join the conversation.

Using "Space Bar" to playback clips in browser 23 Aug 2017 05:37 #90059

  • dgwvideo
  • dgwvideo's Avatar
  • Offline
  • Platinum Boarder
  • Platinum Boarder
  • Posts: 1981
  • Karma: 32
  • Thank you received: 242
I don't see this behavior. Using a dual monitor setup with the browser on the second monitor, if I select a browser clip and press playbar, that clip plays. If I mouse over to the timeline and select a clip, the playbar plays that clip. Even without selecting the clip, if a clip is moused over in either browser or timeline, the appropriate window focus changes and the respective clip plays with playbar.

Turn skimming on in the VIEW menu , or press S to activate it if it's off. Otherwise the timeline current playhead position begins playing instead of the timeline clip. But regardless, window focus should change and the corresponding clip should play when playbar is pressed.
If the problem persists, restart FCPX holding down the OPTION and COMMAND keys and delete preferences when the dialog appears. See if that helps.
Creating history....one edit at a time !

Please Log in or Create an account to join the conversation.

Using "Space Bar" to playback clips in browser 23 Aug 2017 09:31 #90061

  • Karsten Schlüter
  • Karsten Schlüter's Avatar
  • Offline
  • Moderator
  • Moderator
  • Posts: 3692
  • Karma: 61
  • Thank you received: 661

bsquard wrote: … In the past, if you highlighted a clip and hit the space bar, the clip would begin to play back. Now (10.3.4) when you highlight a clip and hit space bar, a drop down appears under Video Roles column.…


yep, same here:



In List-View, it's not enough to select the clip by name, you have to click in the little preview on top…
In Icon-View, space-bar is play/pause

…not sure, that changed with some update (??)…
Attachments:

Please Log in or Create an account to join the conversation.

Using "Space Bar" to playback clips in browser 23 Aug 2017 15:04 #90067

  • DC-W
  • DC-W's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 19
  • Thank you received: 4
Interesting. This isn't happening to me.
Clips still play when pressing spacebar while in list view for me.

Running 10.3.4 on Sierra 10.12.5 on a 5k imac, single monitor.

Please Log in or Create an account to join the conversation.

Using "Space Bar" to playback clips in browser 24 Aug 2017 06:50 #90077

  • Tom Wolsky
  • Tom Wolsky's Avatar
  • Offline
  • Moderator
  • Moderator
  • Posts: 4491
  • Karma: 112
  • Thank you received: 733
With the name selected, if the pointer is over the filmstrip, even if the filmstrip isn’t selected, spacebar will play the clip. If the pointer isn’t over the clip it won’t play.

Please Log in or Create an account to join the conversation.

Using "Space Bar" to playback clips in browser 24 Aug 2017 14:46 #90081

  • ronfya
  • ronfya's Avatar
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Posts: 77
  • Karma: 1
  • Thank you received: 6
I had this behavior since 10.3 and it's really annoying when you try to move fast. And yes the only way to have spacebar play the clip is to have the pointer over the filmstrip. I really don't see why is this. IMHO it's a bug that should be fixed.

Please Log in or Create an account to join the conversation.

Using "Space Bar" to playback clips in browser 26 Aug 2017 14:35 #90104

  • bsquard
  • bsquard's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 11
  • Thank you received: 0
Happening to me on High Sierra beta 10.13 and FCOx 10.3.4. Only happens in list view.

Please Log in or Create an account to join the conversation.

Using "Space Bar" to playback clips in browser 26 Aug 2017 14:37 #90105

  • bsquard
  • bsquard's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 11
  • Thank you received: 0
Having to move the cursor over the flip clip is slow. I want the old behavior where in list view, selected clips play back when you hit the space bar. Now , Video Roles is activated. If there was a way to move the focus to the clip (keyboard shortcut) that would be great.

Please Log in or Create an account to join the conversation.

Using "Space Bar" to playback clips in browser 26 Aug 2017 14:38 #90106

  • bsquard
  • bsquard's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 11
  • Thank you received: 0
Are you using High Sierra (10.13) and FCPx 10.3.4?

Please Log in or Create an account to join the conversation.

Using "Space Bar" to playback clips in browser 29 Aug 2017 07:22 #90127

  • mikkopalo
  • mikkopalo's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 4
  • Thank you received: 0

bsquard wrote: One annoying trait about the latest version of FXPx is a behavior in the browser. In the past, if you highlighted a clip and hit the space bar, the clip would begin to play back. Now (10.3.4) when you highlight a clip and hit space bar, a drop down appears under Video Roles column.


Just right click "Name bar" and uncheck "Video Roles" and "Audio Roles" columns, then this spacebar will play video.



Indeed an annoying bug.
Attachments:

Please Log in or Create an account to join the conversation.

Using "Space Bar" to playback clips in browser 30 Aug 2017 02:55 #90157

  • bsquard
  • bsquard's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 11
  • Thank you received: 0
Brilliant! Thanks...

Please Log in or Create an account to join the conversation.

Using "Space Bar" to playback clips in browser 30 Aug 2017 06:53 #90168

  • ronfya
  • ronfya's Avatar
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Posts: 77
  • Karma: 1
  • Thank you received: 6

mikkopalo wrote:

bsquard wrote: One annoying trait about the latest version of FXPx is a behavior in the browser. In the past, if you highlighted a clip and hit the space bar, the clip would begin to play back. Now (10.3.4) when you highlight a clip and hit space bar, a drop down appears under Video Roles column.


Just right click "Name bar" and uncheck "Video Roles" and "Audio Roles" columns, then this spacebar will play video.



Indeed an annoying bug.


Good workaround mikkopalo ! Thanks
Unfortunately, it's only a workaround ... since having roles in the browser is kinda useful.
Apple please fix this.

Please Log in or Create an account to join the conversation.

Using "Space Bar" to playback clips in browser 01 Sep 2017 15:31 #90242

  • lichinho
  • lichinho's Avatar
  • Offline
  • Platinum Boarder
  • Platinum Boarder
  • Posts: 335
  • Karma: 10
  • Thank you received: 62
Funny, it always works correctly for me. No matter if roles are checked or not, no matter whether the cursor is over the playstrip or not, no matter if single screen or two screens.

Click a click in the browser list, press Space to play/pause is working for me all the time. Running FCP X 10.3.4 on Sierra 10.12.6.

Please Log in or Create an account to join the conversation.

Using "Space Bar" to playback clips in browser 01 Sep 2017 15:44 #90243

  • bsquard
  • bsquard's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 11
  • Thank you received: 0
Might be a High Sierra 10.13 thing, but it definitely happens as I described on my system dual monitor.

Please Log in or Create an account to join the conversation.

Using "Space Bar" to playback clips in browser 01 Sep 2017 16:31 #90250

  • Karsten Schlüter
  • Karsten Schlüter's Avatar
  • Offline
  • Moderator
  • Moderator
  • Posts: 3692
  • Karma: 61
  • Thank you received: 661

bsquard wrote: Might be a High Sierra 10.13 thing,….


definitely not here… HighSierra never touched my Mini (yet).
But unchecking the columns does the trick… indeed.

conspiracy theory:
since Apple confessed, they installed APFS 'behind users back', they do with betas of FCPX too! *
(read my post about diff. versions of the TimeCode Generator with a hidden feature!!)

:woohoo: LOL :silly:


* meant as a joke!!!

Please Log in or Create an account to join the conversation.

Using "Space Bar" to playback clips in browser 01 Sep 2017 21:26 #90259

  • FCPX.guru
  • FCPX.guru's Avatar
  • Offline
  • Platinum Boarder
  • Platinum Boarder
  • bbalser.com
  • Posts: 3595
  • Karma: 34
  • Thank you received: 497
I've been running FCPX on High Sierra developer beta since it was released. FCPX has tons of bugs. I'd not do serious paying work with HS yet.

Please Log in or Create an account to join the conversation.

Using "Space Bar" to playback clips in browser 25 Sep 2017 18:43 #90784

  • DC-W
  • DC-W's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 19
  • Thank you received: 4
Anyone make any discoveries on this? This is happening on another seat of FCPX we have and has only been doing so since updating to FCPX 10.3.4 on OSX 10.12.6.

Mine is still unaffected, mercifully. Same OS and version too.

Please Log in or Create an account to join the conversation.

Using "Space Bar" to playback clips in browser 29 Sep 2017 22:53 #90876

  • jamecude
  • jamecude's Avatar
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Posts: 42
  • Karma: 2
  • Thank you received: 5
In System Preferences > Keyboard > Shortcuts, set Full Keyboard Access to “Text boxes and lists only.”

Please Log in or Create an account to join the conversation.

Using "Space Bar" to playback clips in browser 29 Sep 2017 23:01 #90878

  • Tom Wolsky
  • Tom Wolsky's Avatar
  • Offline
  • Moderator
  • Moderator
  • Posts: 4491
  • Karma: 112
  • Thank you received: 733
THAnk you James. How did you find that?

Please Log in or Create an account to join the conversation.

Using "Space Bar" to playback clips in browser 02 Oct 2017 23:04 #90928

  • ronfya
  • ronfya's Avatar
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Posts: 77
  • Karma: 1
  • Thank you received: 6
Thanks jamecude,
I will check if it works for me. Though it's still a workaround cause really I don't want to change that option on a regular basis. I use the tab key to navigate between field too often and in some cases it does not work if not set to "all controls".

cheers

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
  • 2