fbpx
✎ Latest Forum Posts
✎ Latest Free FCPX Effects
Timsk replied to the topic 'Need a copy of FCPX compatible with High Sierra' in the forum. 4 months ago

I do have Mojave installed (now) and i do have FCPX installed on Mojave but it runs slowly because my graphics card is using the generic OSX driver for reasons I have explained previously. And Apple Support have told me they no longer supply FCPX for High Sierra which is extremely annoying because High Sierra is not that old but they are quite unmoving on that point.

However, it sounds like you are saying that if I downgrade to High Sierra that I should then be able to download a High Sierra compatible version of FCPX. I am not convinced that is correct given that I was on High Sierra in January when I purchased and downloaded FCPX originally and then got forced into an upgrade cycle to try and install the DMG - however, i will check with Apple Support if they agree that strategy would work - because if they agree, and I downgrade, if i have problems I will have some leverage to try and make them give me the correct DMG.

Read More...

Timsk replied to the topic 'Need a copy of FCPX compatible with High Sierra' in the forum. 4 months ago

HipHopSuperman, that is very interesting - maybe when I was on High Sierra and I purchased FCPX and it allowed me to download it (even though it was a Mojave DMG) there was some kind of bug with the app store that allowed the download. Anyway, your experience indicates that even if I downgrade back to High Sierra I won't be allowed to install FCPX for High Sierra.

Which leads me back to my issue, does anyone know a way to get a copy of FCPX for High Sierra that *isn't* through the Apple App Store? Maybe some internet repository of archived versions somewhere? Because if not I have to forget about my new video card (which doesn't work on Mojave despite being certified by Apple) and purchase another video card to try and make everything work with Mojave.

Read More...

Timsk replied to the topic 'Need a copy of FCPX compatible with High Sierra' in the forum. 4 months ago

You are being clear, and I appreciate you trying to help, but I'm telling you I WAS on High Sierra when I purchased and downloaded FCPX from the app store, it turned out to be FCPX for Mojave because they won't sell you FCPX for High Sierra anymore, I confirmed that with Apple Support, they told me to upgrade to Mojave, to do so it turned out I needed to purchase a 'metal compatible' graphics card, then it turned out the Nvidia graphics card that was on the list of compatible graphics cards from apple did not have a driver for Mojave, so now I either need to buy a new graphics card or downgrade my OS and re-install FCPX.

So while you are logically correct that if you have a specific Mac OSX operating system installed and you download FCPX from the app store, that it SHOULD give you FCPX for your version of OSX, I know for a fact that does not work because I was on High Sierra and the FCPX I got from the App Store was for Mojave, and Apple Support would not supply me with a version of FCPX for High Sierra...

Read More...

Timsk replied to the topic 'Need a copy of FCPX compatible with High Sierra' in the forum. 4 months ago

Unfortunately that is not correct, I *was* on high sierra and I paid for and downloaded FCPX from the App Store and it wouldn't install. After much hassle with Apple Support it turns out that I needed to be on Mojave (10.14.6), and they could not supply me with a DMG that would install on High Sierra (10.13.6). To say the least I was astonished given that High Sierra is not really that old. So that required me to upgrade to Mojave (10.14.6), and Mojave (10.14.6) requires the 'metal-compatible' graphics card, so I purchased the Nvidia because Apple's link said it would work, then I found out that Nvidia don't make a driver for Mojave (10.14.6) only for High Sierra (10.13.6). Thus the need for an executable / DMG that will work on High Sierra to come from some source that is not Apple, or I just say goodbye to the money I spent on the Nvidia video card and I purchase another video card that actually has a driver for Mojave (10.14.6).

Read More...

Timsk replied to the topic 'Need a copy of FCPX compatible with High Sierra' in the forum. 4 months ago

Tom, apologies if I wasn't clear. When I said 10.14.6 I was talking about Mojave.

The app store won't let you purchase FCPX for High Sierra (10.13.6) anymore. They only let you purchase for Mojave (10.14.6).

With a 2012 Mac Pro, you cannot install Mojave using the original graphics card, because the original graphics card is not metal-compatible. Thus you need to purchase a metal-compatible graphics card. I purchased an NVIDIA Quadro K5000 for Mac per support.apple.com/en-us/HT208898 because that is one of the few supported graphics cards. BUT, it turns out that Nvidia don't supply a driver for Mojave (10.14.6) only for High Sierra (10.13.6). Thus, the video card that Apple says is compatible with Mojave isn't actually compatible with Mojave because Nvidia don't make a driver, and when I try and use the generic apple drivers with the Nvidia K5000, the Mac Pro boots up but is very unreliable when trying to do anything that involves the graphics card (gets very slow, hangs, etc).

So either I need to downgrade to High Sierra (10.13.6) and run FCPX on 10.13.6 OR I need to try and re-sell the Nvidia K5000 and buy a different metal-compatible graphics card that will work with Mojave (10.14.6).

But if I downgrade, I need to get a copy of FCPX that will run on high sierra (10.13.6) because Apple will no longer give you a copy that runs on high sierra (10.13.6).

Read More...

Timsk created a new topic ' Need a copy of FCPX compatible with High Sierra' in the forum. 4 months ago

Hi, I have an unusual situation. I need to get a copy of FCPX that will work on High Sierra 10.13.6 because that is the latest version of OSX that Nvidia make a driver for. However, although I have a license for FCPX, Apple won't let me download a copy of FCPX from the App Store that is compatible with 10.13.6, the latest version I can download is for 10.14.6, and my Nvidia card doesn't work well with the generic OSX driver.

Does anyone know how I can get hold of a version of FCPX for 10.13.6? I do have a license, I just don't have the correct install dmg.

Read More...

Timsk replied to the topic 'Optimizing FCPX backups' in the forum. 4 months ago

That's great info many thanks!!

Read More...

Timsk thanked Larrie in topic Optimizing FCPX backups 4 months ago
Timsk created a new topic ' Optimizing FCPX backups' in the forum. 4 months ago

Hi, I am trying to save space in my Dropbox account - if I don't back up proxy files and transcoded files, can these be regenerated? I realize it may take a long time to regenerate them, but I would be willing to do that to save space. Is not backing up proxy and transcoded files a bad thing to do?

Read More...