fbpx
✎ Latest Forum Posts
✎ Latest Free FCPX Effects

Thanks Davis,
Worthwhile test in the name of thoroughness.
The issue is just the viewer in FCPX though.

Gamma on files is fine on export, and any preview of files in FC (filmstrip in browser, or in Import panel) has the shift only on the active frame and not elsewhere. I tested this again last night with archival unedited footage from years of past projects.

I did run the tests you mentioned though. No shifts in gamma. I tried everything - raw, Compressor-re-encoded, etc. It's just the FCPX viewer. Not sure where to go from here except a different Metal vid card.
Read More...

Lurker de-lurking here...
I have a 2009 MacPro hacked to run High Sierra (4.1->5.1). Flashed AMD Radeon HD 7970 card and 2 calibrated Cinema Displays.

Ever since FCP 10.4.6 (or perhaps 10.4.4?) my FCPX viewer is displaying things with incorrect gamma. Basically the big classic 1.8/2.2 shift. Exported projects are displayed properly in Quicktime, etc.. I thought the days of Macs misinterpreting 1.8/2.2 were long gone......

The filmstrip previews in the file browser are correct gamma, except for the frame my cursor is hovering over - which exhibits the same display problem. I'm currently running Panasonic GH4 standard files (non-V-Log) with no special setting or treatment on them, but I've observed the problem with older FCPX projects I've brought out of archives to test, and these include some different footage.

I read somewhere that FCPX performs a gamma adjustment based on the system color profile and source footage. I've tried using different profiles, including those w/version 2 versus version 4 profiles, and even old archival Apple ones like HD 709-A, etc, to no avail.

Though the 7970 card is not on the approved list, it's Metal-capabable, though I know the OpenCL version is 1.x series, if that matters. I've had no other graphics issues anywhere except the FCPX viewer.

Is this just some new deep under-the-hood FCPX/High Sierra behavior that just doesn't work with my MP2009/7970 setup? Unfortunately I don't have another more modern card at the moment to swap out. I certainly don't want to add a temporary gamma adjustment to all the many chunks of my project.

Thanks for any wisdom you guys can offer... I may resort to installing Mohave on an external boot drive to see what happens.
Read More...