fcp.co logo transparent
fcp clapperboard
Welcome, Guest
Username: Password: Remember me
25 Jan 2021
New boarders will have their posts moderated - Don't worry if you cannot see your post immediately.
Read More...
  • Page:
  • 1

TOPIC: Can I update to a recent version? Don't want to switch to 10.4.5 yet...

Can I update to a recent version? Don't want to switch to 10.4.5 yet... 16 Nov 2020 22:59 #110901

  • screendor
  • screendor's Avatar Topic Author
  • Offline
  • Gold Boarder
  • Gold Boarder
  • Posts: 249
  • Karma: 2
  • Thank you received: 9
Hey folks. Quick question. I have 3 machines running FCPX. My main machine has version 10.4.10.

I need to have another editor cut on a machine that is 10.4.8--it can't open the copied library. Needs to update.

Usually no problem, but FCP just updated to 10.5 and I don't want to update all machines yet. Where/how can I update the 10.4.8 machine to 10.4.10?

Not the App Store. It only offers the latest 10.4.5 version.

Or do I just have to bite the bullet?

Thanks!!!

Please Log in or Create an account to join the conversation.

Can I update to a recent version? Don't want to switch to 10.4.5 yet... 17 Nov 2020 01:22 #110904

  • Ben Balser
  • Ben Balser's Avatar
  • Offline
  • Platinum Boarder
  • Platinum Boarder
  • bbalser.com
  • Posts: 4050
  • Karma: 34
  • Thank you received: 571
You should be OK with 10.5. What macOS version? You could also simply copy the application from one Applications folder on one Mac to the other.

Please Log in or Create an account to join the conversation.

  • Page:
  • 1