fcp.co logo transparent
fcp clapperboard
Welcome, Guest
Username: Password: Remember me
25 Jan 2021
New boarders will have their posts moderated - Don't worry if you cannot see your post immediately.
  • Page:
  • 1


URGENT XML HELP NEEDED!!! THANK YOU!!! 24 Apr 2019 11:33 #99784

This is my burning question FCP X related:

I’m working together with the director on a 90min documentary Film.
Over ten years in shooting, mixed Footage (MiniDV - 4K Drone Footage, all prepared via KYNO into Apple ProRes 422, optimized and Proxies), over 6TB in total.

The Setting is as follows:

Me (iMac 5K and Raid with full Res media),
Workflow: 1. Ingest via Kyno, Import into FCP X, Events and Projects, Optimized and Proxies generated.
2. Editing, Fine Editing, Sound Editing (with Audio Roles), Subtitle Export

Director (iMac 5K, external Hard Drive with Proxies)
Workflow: 1. Principal Editing (it’s in Russian, I don't speak), subtitling, and Title Layout
2. XML Transfer via XML Export in FCP X to me

All worked fine the last 6 months, I’ll got the XML’s, imported them into my FCP X and did the fine tuning/editing and exporting with subtiles from Original Media for preview purposes.

Now I’ll had to Pre-Mix and sort and edit the Audio (Audio Roles, panning, Channel selection, mono/stereo, Volume adjustments, etc..)
Afterwards I exported an XML and send it back to the director so that he can control it and Preview it and make changes.

All worked pretty well, until yesterday: I finished audio editing and did the usual XML export and send the director the XML:
Then the Problem started: When he tried to import the XML FCP X crashed (thread 0; dispatch queue).

We've taken the following steps to resolve this problem:

• He has had some issues with Mojave and FCP X before and so we decided to reinstall Mojave and FCP X, but problem persisted.
• I did an XML check (Digital Rebellion) and a corrupt clip finding check (Digital Rebellion) and found two corrupted clips: Sound FX Files from FCP X FX Library in FCP X: I deleted them from the timeline, exported XML, he tried to import: again FCP X chrashed
• I made a new Project, copy and paste, XML export in two different ways (1.8 and 1.7), same result, FCP X chrashed
• Tried different Project Version, same result

I’m wondering if the following steps can help me:

• I will create new projects with chunks from original project to find out where about in my original project the problem might be: 15min Project, XML Export; 30min Project, XML Export; 45min Project, XML Export; 60min Project, XML Export; 75min Project, XML Export
• Would it make sense to create a new FCP X library and copy only Final Project into it and try XML export
• Are there tools for checking FCP X library?

Please help us as we need to finish the Film asap. And we are extremely tight on schedule and of course budget.
Any help is very much appreciated!


P.S.: pls find enclosed the troublemaker XML File

Please Log in to join the conversation.

URGENT XML HELP NEEDED!!! THANK YOU!!! 25 Apr 2019 18:11 #99797

  • Doug
  • Doug's Avatar
  • Offline
  • Senior Member
  • Senior Member
  • Posts: 72
  • Karma: 2
  • Thank you received: 16
Wish I had more to add, but one thought:

Is your media stored outside of the Library? If so, you should be able to compress down the Library to a fairly small size, enough that you can send the entire library over rather than XMLs. Perhaps give that a try and see if the director is able to open the library itself on his machine?

Best of luck! Let us know how your tests pan out.


Please Log in to join the conversation.

  • Page:
  • 1