Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: fcpx copy-paste bug (v10.4.2 + 10.4.5)

fcpx copy-paste bug (v10.4.2 + 10.4.5) 13 Mar 2019 18:30 #99280

  • bmoo
  • bmoo's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 1
  • Thank you received: 0
Here is the editing situation : I am editing various file types and codecs on a 1080p29,97 timeline .
Usually fcpx does this without complaining. I use a lot the Copy - Paste as connected clip function. On some clips nothing is pasted… or what is pasted is the last clip or selection in the Clipboard.

Here are the tests I ran last night :
Put any clip on a 1080p29,97 timeline, make a selection with the Range Tool, Copy and Paste as Connected Clip.
It does work when the clip is:
- ProRes RAW, ProRes HQ or ProRes 29,97 or 59,94 HD or 4k
- AVCHD, H264 1080p 59,94

It does not work if the clip is :
- ProRes RAW 2K 240 fps, even if conformed/adapted at the timeline frame rate
- ProRes 422 or ProRes HQ 1080p30
It will not copy the selection, but will paste the previous content of the clipboard. (I did not try more codecs-frame rates combinations)

For "fun" I tried the reverse situation: create a 30p timeline and edit 29,97 clips. The result is what expected: it will Copy-Paste 30p clips but not 29,97 or 59,94 clips.
To make sure, I converted one of the 30p files into 29,97 frame rate and imported it for edit. On a 29,97 timeline the new 29,97 clip Selected-Copied-Pasted, but the 30p is not.

First conclusion : it clearly seems to be related to the frame rate, not the codec as I first thought. Now there is the exact same number of frames in both files. This is where I do not understand why it makes a difference to fcpx? I thought first it could be a bug with ProRes RAW files in fcpx 10.4.2, so I updated to the last version (10.4.5). Same thing happens.
Is there something I miss, is it a bug?
Any light on this will be welcome. Thanks

Please Log in or Create an account to join the conversation.

  • Page:
  • 1