fbpx
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: Artifacts from overlapping clips

Artifacts from overlapping clips 08 Feb 2020 21:53 #104485

  • jmb379
  • jmb379's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 2
  • Thank you received: 1
Hey eveyone! Glad to be joing the forum! I just started with Mac and FCPX and I'm loving it!

~except occasionally when I'm not...let's try to fix that :side:

I have been seeing a strange artifact at a few places in a 4k video shot on an iPhone XS where certain clips in certain orders result in a strange overlap of parts of an earlier clips with a later one. I am not sure why this is happening but I am looking for a source solution rather than a 'print-and-patch' workaround, so if anybody knows if this is a cache problem or something else I would love to know!

Please Log in or Create an account to join the conversation.

Artifacts from overlapping clips 09 Feb 2020 15:56 #104493

  • jmb379
  • jmb379's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 2
  • Thank you received: 1
Here are screenshots of the issue
Attachments:

Please Log in or Create an account to join the conversation.

Artifacts from overlapping clips 10 Feb 2020 13:41 #104510

  • joema
  • joema's Avatar
  • Offline
  • Platinum Boarder
  • Platinum Boarder
  • Posts: 1337
  • Karma: 27
  • Thank you received: 279
The iPhone XS video might be HEVC and there are some possible issues with FCPX handling HEVC starting with 10.4.7. I have not seen your specific problem and HEVC test clips from my iPhone 11 work OK, but it's possible.

If you had 10.4.6 on any machine you could just swap the FCPX file bundle to test this, although you'd have to re-import to a new library since the library was upgraded between 10.4.6 and 10.4.7. For this reason before an upgrade it's a good idea to rename or save a copy of the FCPX app in the /Applications folder. That way if you suspect a problem it's easy to temporarily revert to the previous version for testing.

I'd suggest taking the problem clips you mentioned and externally transcoding those to H.264 using HandBrake. Then import those to a new test library, assemble them in the same order and see if the problem goes away. The below video shows how to transcode HEVC to H.264.

Please Log in or Create an account to join the conversation.

Last edit: by joema.
  • Page:
  • 1