Welcome, Guest
Username: Password: Remember me

TOPIC: 23.976216 playback issues

23.976216 playback issues 14 Dec 2019 16:14 #103229

  • lock
  • lock's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 3
  • Karma: 0
Hi guys, I'm trying to import an 23.976216 framerate video in FCP. I think to understand 23.97 and 23.98 are the same thing, however the imported video is not fluid. It's all "spikey" like if the framerate was changed and there were frames drops.
Importing it in a 60fps project improves a bit the play but, of course, I'd like to keep the original framerate.

I'm running out of ideas, I'm new to FCP so maybe i'm doing some mistake during the import.

One question: can't I open a media file and let FCP to automatically create a project for it, instead of first decide myself all the features? Thanks.
The administrator has disabled public write access.

23.976216 playback issues 15 Dec 2019 09:23 #103246

  • Axel
  • Axel's Avatar
  • NOW ONLINE
  • Platinum Boarder
  • Posts: 543
  • Thank you received: 68
  • Karma: 10
lock wrote:
One question: can't I open a media file and let FCP to automatically create a project for it, instead of first decide myself all the features?

Yes. When you create a new project, use "Automatic Settings" instead of "Custom Settings".

"23.976216" is long for "23,98". And it actually doesn't matter much, since "23,98", "24" and "25" can't stutter in an FCPX timeline due to the mixed frame rate / automatic frame rate conversion of these three. What that means is that FCP doesn't ask you how it should interpret a framerate that's different from the one you arbitrarily set (in Inspector, the "frame rate conversion" - field doesn't appear. It did, if you used 29,97 or 30 in a 24 timeline). It automatically plays back every frame at the relative duration of the project framerate. No skipped frames, no added frames. Resulting in a slightly different duration of the individual clips. This can be a problem (for instance) if you had multiple cameras with different framerates but one external audio source. But it can't cause stuttering playback.

So I don't know where you messed up. But there can be various reasons why playback isn't smooth. Your machine may be too weak to play back, say, H.264 UHD in realtime. Solution: edit with proxies. In theory, you could also edit from a USB 2 stick or from a single HDD (but then you 'd complain about general performance). Another typical reason is the wrong monitor refresh rate. Many cheap gaming monitors can cause this. If that's possible, check by exporting for your iPhone or your modern Smart TV. If it doesn't stutter there, get a better monitor.
Last Edit: 15 Dec 2019 09:44 by Axel.
The administrator has disabled public write access.

23.976216 playback issues 15 Dec 2019 11:38 #103250

  • lock
  • lock's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 3
  • Karma: 0
Thanks for your answer, Axel.

Yes, I discovered the "automatic settings" after writing this post and it's a great thing. At least I don't have to write down all video settings before creating a new project. :)

I still didn't understand where is the problem with my files. Yes, my Mac is a bit old, but usually doesn't have problems managing 1080p video files (when it does it's due tp hard disk issues, rather than CPU ones).

I was able to "solve" the problem re-encoding the video with Handbrake, forcing a frame rate of 23.976 (that should be the same of the source, btw) and choosing "constant framerate" (I've no idea about this, I was thinking framerate was always constant; the other option was "peak framerate). This fixed the video. FCP still complains about "video properties not standard" but I guess it referres to dimensions that are custom.

After importing, the video plays smooth. Of course there's an additional encoding in the middle, and that's not a good thing. I've just used max quality hoping the loss of details would be minimal.
The administrator has disabled public write access.

23.976216 playback issues 16 Dec 2019 06:10 #103271

  • Axel
  • Axel's Avatar
  • NOW ONLINE
  • Platinum Boarder
  • Posts: 543
  • Thank you received: 68
  • Karma: 10
Just guessing: smartphone video?
It‘s the only instance where I encountered variable framerates. Please use Filmic Pro in the future.
The administrator has disabled public write access.

23.976216 playback issues 17 Dec 2019 00:17 #103297

  • lock
  • lock's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 3
  • Karma: 0
I don't think. A friend gave me this video some years ago. I guess he encoded it himself to h264, but it was a time of tries and experiments and maybe he messed something up.
The administrator has disabled public write access.