Welcome, Guest
Username: Password: Remember me

TOPIC: Cursor flashes between Select and Position tools when moved to the edge of a clip, without sticking

Cursor flashes between Select and Position tools when moved to the edge of a clip, without sticking 25 Apr 2019 21:09 #99799

  • flaminghick
  • flaminghick's Avatar
  • OFFLINE
  • Junior Boarder
  • Posts: 30
  • Karma: 0
Hey there,

I'm not sure when this started exactly, but my Select (arrow) tool, won't change into the Position tool (the one it changes into so you can lengthen or shorten a clip with the mouse). I move the arrow to the edge of the clip, and it flashes back and forth between the two tools, and will only work as the Position tool if I grab the clip while the mouse is moving. If I pause, it reverts to the selection tool, but I'm trying to use the Position tool which it should automatically switch to when the arrow it moved to the edge of the clip.

It had worked flawlessly for years, but in the past few months, I'm guessing after a certain update, it seems broken.

I'm on a 2017 Macbook Pro with the most recent operating system. I've done one update of FCPX since this started and nothing changed. If anyone has an idea, I'd appreciate it.
The administrator has disabled public write access.

Cursor flashes between Select and Position tools when moved to the edge of a clip, without sticking 25 Apr 2019 22:05 #99800

  • FCPX.guru
  • FCPX.guru's Avatar
  • OFFLINE
  • Platinum Boarder
  • bbalser.com
  • Posts: 2539
  • Thank you received: 330
  • Karma: 32
OK, just to cover the basics.
A makes it the Select (arrow tool), arrowhead with a tail.
P makes it the position tool (magnetic characteristics disabled) - arrowhead with no tail.
T is the trim tool which I think you have selected by accident.

ScreenShot2019-04-25at5.04.54PM.png
Last Edit: 25 Apr 2019 22:06 by FCPX.guru.
The administrator has disabled public write access.

Cursor flashes between Select and Position tools when moved to the edge of a clip, without sticking 25 Apr 2019 22:11 #99801

  • flaminghick
  • flaminghick's Avatar
  • OFFLINE
  • Junior Boarder
  • Posts: 30
  • Karma: 0
No, I never have the trim tool selected. Always on the Select tool, which should automatically become the Position tool (I think) when you move it to the edge of the clip.

I can still grab the clip, the cursor is just going haywire between the Select and Position tool and never settles. Just this constant flashing back and forth whenever I move the cursor near the end of a clip.
The administrator has disabled public write access.

Cursor flashes between Select and Position tools when moved to the edge of a clip, without sticking 26 Apr 2019 15:38 #99809

  • FCPX.guru
  • FCPX.guru's Avatar
  • OFFLINE
  • Platinum Boarder
  • bbalser.com
  • Posts: 2539
  • Thank you received: 330
  • Karma: 32
Ah, you may be zoomed out to far in the Timeline. If you are too far out, you lose some accuracy. Does zooming in help at all? (Cmd with + and - keys)?
The administrator has disabled public write access.

Cursor flashes between Select and Position tools when moved to the edge of a clip, without sticking 26 Apr 2019 15:42 #99810

  • flaminghick
  • flaminghick's Avatar
  • OFFLINE
  • Junior Boarder
  • Posts: 30
  • Karma: 0
Thanks for the suggestion, but no.

This is a case where something that used to work one way now feels like it's glitching out or something. I know my way around the software very well having been using it for years. I'm not sure what's up exactly. It seems like no one else has encountered this issue.
The administrator has disabled public write access.

Cursor flashes between Select and Position tools when moved to the edge of a clip, without sticking 26 Apr 2019 17:43 #99811

  • flaminghick
  • flaminghick's Avatar
  • OFFLINE
  • Junior Boarder
  • Posts: 30
  • Karma: 0
Okay so I've realized that this is also happening with Safari. When I go to drag the corner of the browser window, the arrow flickers back and forth between the normal arrow and the two-way arrow rather than sticking as the two way arrow. This seems to be a Mac OS issue.
The administrator has disabled public write access.

Cursor flashes between Select and Position tools when moved to the edge of a clip, without sticking 26 Apr 2019 20:32 #99816

  • FCPX.guru
  • FCPX.guru's Avatar
  • OFFLINE
  • Platinum Boarder
  • bbalser.com
  • Posts: 2539
  • Thank you received: 330
  • Karma: 32
I saw something similar to that on my rMBP a while back. I reset the tracking speed of the trackpad, used it a bit, then set it back where I wanted it to be. That seems to fix it. May not work for you, but anything is worth a shot.

I also try using a mouse, or external trackpad, see if that does the same thing. Then you'd know if it is the OS or something physically wrong with the laptop's trackpad.

Yeah, I'd review some system preferences, run Disk Utilitie's First Aid, verify free space just for good measure. Can't hurt. That's a super annoying issue you've got there.
The administrator has disabled public write access.

Cursor flashes between Select and Position tools when moved to the edge of a clip, without sticking 26 Apr 2019 20:35 #99817

  • flaminghick
  • flaminghick's Avatar
  • OFFLINE
  • Junior Boarder
  • Posts: 30
  • Karma: 0
Hey thanks for your suggestions.

So I ended up finding a solution from another forum. All I had to do was log out, log in as guest, then log out and log back into my usual account and the problem was solved.

Definitely just some weird OS issue. Glad to have found an easy solution. Should have looked for it weeks ago :)
The administrator has disabled public write access.