Welcome, Guest
Username: Password: Remember me

TOPIC: Why can´t I update from FCPX 10.2.3

Why can´t I update from FCPX 10.2.3 11 Dec 2018 19:36 #98122

  • Hastings
  • Hastings's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 1
  • Karma: 0
The library "xxxx" is damaged and cannot be updated.

Hello,

This is my first topic on this forum, and I hope I also can help people in the future.
I have already look for answer on the internet and it seems no one have a good answer on my problem.
This one is a tricky one...

The story is: I had a old macbook pro 2.6Mhz (2015) and FCPX 10.2.3. All my projects are saved on extern HDD drive. I know that the files is working. Now I have a new computer, a Macbook pro on mac os sierra 10.13.6. and FCPX 10.4.
And sold the old one... When I try to open the fcpbudle by dubble klick on my external drive, a get a message I must update. When I do update I get the message : The library "xxxx" is damaged and cannot be updated.
I so frustrated and need help to solved the problem. I have 2-3 hard drives that have the FCPX version 10.2.3 so I really want to solve my problem.

One solution is that I install a old Mac os and a old FCPX version (10.2.3) on my NEW Macbook Pro. But it seams a waste of my new computer and I want to use all the new things on the lates version of FCPX.
Please a need all the help I can get!

Solution:
Close the FCPX. Right klick on the fcpbundle and ”show content” of the xxxx.fcpbundle on the external drive.
Move the files settings.plist and current version.flexolibrary from the external drive to a safe place (destop). Do not delete the files for now.

Press command + option and open the FCPX.
Then delete preferences.
Then go filen open library and others. Find our fcpbundle.
Update! Finish!
Last Edit: 12 Dec 2018 09:14 by Hastings.
The administrator has disabled public write access.