Welcome, Guest
Username: Password: Remember me

TOPIC: Can't Open Library , Permission Issue in use by local ??

Can't Open Library , Permission Issue in use by local ?? 16 Feb 2017 06:13 #85770

  • milesdavis100
  • milesdavis100's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 19
  • Thank you received: 1
  • Karma: 0
Hi ,

I'm really struggling with an issue . I have FCP X libraries that I backed up on a old computer with Time Machine. I am trying to use them on my new computer . When I attempt to load them I get an error that says

The document "Untitled" could not be opened. Permission denied
"Untitled" is already in use by MY-MBP on 'miles-macbook-pro.local".

I have tried everything I have read online...

1 - rebooted
2 - made sure permissions are set for red/write in all areas on the drive, on the folder, on the library and all related files
3 - I tried to copy the internals of the library into a new library, and that didn't work at all nothing showed up
4 - copy library from external drive to my computers own HD , same issue / error

I cannot find a solution for this anywhere ! It's so frustrating and I need to access these files .

Help. Please!

thank you - MD
The administrator has disabled public write access.

Can't Open Library , Permission Issue in use by local ?? 16 Feb 2017 14:32 #85784

  • FCPX.guru
  • FCPX.guru's Avatar
  • OFFLINE
  • Platinum Boarder
  • bbalser.com
  • Posts: 2462
  • Thank you received: 321
  • Karma: 32
I've seen this once before, copying Libraries from one RAID to another. I could not delete a specific Library off of the old RAID, it was fine on the new one. Turned out to be a corrupted folder that couldn't be trashed or anything. It was stuck on "being used". I did a web search of fixing a file flagged as "in use" when it wasn't. There are several things you can try, none worked for me. Over time, and a few re-boots, and the folder deleted fine.

Not that any of this solves your issue, but there's a flag on every file and folder locking it as "in use" in specific situations. You seem to have a Library that has a folder or file inside of it with this issue.

I'm sure someone here has a solution.
The administrator has disabled public write access.

Can't Open Library , Permission Issue in use by local ?? 16 Feb 2017 18:03 #85809

  • milesdavis100
  • milesdavis100's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 19
  • Thank you received: 1
  • Karma: 0
Hi,

Thanks for the reply. Its crazy because I figure there must be some simple fix. Clearly the files are within the Library if you browse it , but I can't get the library to load no matter what I do .

I checked via Get Info , and the 'locked' tab is not checked -- stop sure if the flag you're referring to is something else though. I wasn't able to find anything about that yet via my first searches.

Do you or anyone know if it's possible to migrate projects/events from within a Library manually into another one?

I attempted it just moving it one for one via finder - but when I brought it back to FCP it didn't work .

So strange and frustrating !

Thanks in advance , MD
The administrator has disabled public write access.

Can't Open Library , Permission Issue in use by local ?? 16 Feb 2017 20:22 #85811

  • ronny courtens
  • ronny courtens's Avatar
  • OFFLINE
  • Moderator
  • Posts: 4182
  • Thank you received: 884
  • Karma: 195
Hello Miles, welcome to the forums.

If you are not afraid of Terminal, or if you are willing to download a free little application that enables you to show Hidden Files on your Mac, there may be a way to fix this.

The reason why you cannot open the Library is probably because the .lock file, the .lock-dir folder and/or the lock-info file that are hidden inside the Library package are corrupted. The trick is to open the Library package (with FCP X closed of course) and to trash these files. This is harmless,because these files are automatically recreated when you open the Library in FCP X.

But of course first we need to be able to see these hidden files. There is a Terminal command that enables Show Hidden Files (and another one to disable this function), or you can download a free utility to easily enable/disable Hidden Files in the task bar. I will point you to the utility, if you prefer the Terminal commands let me know and I will post them here.

The utility is called Funter: nektony.com/products/funter

Download the app and drag it into your Applications folder.
Then double-click the app icon to open the app.
A little black button will appear at the right side of your top task bar. Click the button and set the switch to ON:

Schermafbeelding2017-02-16om21.01.59.png


Now go to the problematic Library (which should NOT be on the Time Machine drive anymore) and open the package. You will see a lot of new files that you have never seen before. Never mind, these are the only ones you should care about:

02_2017-02-16.jpg


Trash them, close the package and then try to open the Library in FCP X. This has worked for many others before, I hope you are in the camp of the lucky ones!

NOTE: after this procedure, switch the Funter button back to Hide Hidden Files and delete the app. Hidden Files must ALWAYS remain hidden except for troubleshooting. Messing around with hidden files is a recipe for disaster.

- Ronny
The administrator has disabled public write access.

Can't Open Library , Permission Issue in use by local ?? 17 Feb 2017 00:46 #85819

  • milesdavis100
  • milesdavis100's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 19
  • Thank you received: 1
  • Karma: 0
Hi !

Thank you so much for this info. Its something new I haven't tried yet and I'm hoping it's edging my closer to a solution .

I followed your instructions and went through, deleted the lock files. Note . There was not a lock-dir folder in the library just the two hidden lock files .

I deleted them, closed the packaged, reopened FCP and launched the library ,...

however now I am getting this error :

The document "Library" could not be opened. Permission denied
Libraries require read and write permission

I went again to get info, double checked - everyone has read + write access . I even added myself again as admin just to be sure and getting the same error.

Note this did come from the Time Machine vault as described, but I made a duplicate outside the TM vault

Any ideas??

Thank you !
The administrator has disabled public write access.

Can't Open Library , Permission Issue in use by local ?? 19 Feb 2017 08:11 #85877

  • ronny courtens
  • ronny courtens's Avatar
  • OFFLINE
  • Moderator
  • Posts: 4182
  • Thank you received: 884
  • Karma: 195
Sorry for the late reply. This seems a little more complex than expected.

- Unmount and mount the drive that contains the library, or restart the computer if the Library is on an internal drive. If that does not work:

- Double-check the drive and Library permissions. You need to have Read/Write access to all folders and included files. If that does not work:

- Open the Library package again (with FCP X closed), trash the CurrentVersion.flexolibrary file and the _Sync_ file (if there is one) and try to open the Library. If that does not work:

Contact Apple support. They will guide you through a deeper troubleshooting process.

- Ronny
The administrator has disabled public write access.

Can't Open Library , Permission Issue in use by local ?? 19 Feb 2017 18:48 #85910

  • milesdavis100
  • milesdavis100's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 19
  • Thank you received: 1
  • Karma: 0
Hi,

Thanks for getting back . I'm away from the drive today but I will try everything you listed for sure.

I tried to load/unload the drive and also move the library onto my MacBook directly, none of those worked.

I will give the other options a try and report back if it works. I did adjust to be sure the drive had read/write and folders and all is good there

Maybe deleting those other files will do the trick. Strangely, other libraries on the drive don't have the issue

I was curious if Apple would actually be able to help or not.

thank you! Derek
The administrator has disabled public write access.

Can't Open Library , Permission Issue in use by local ?? 27 Feb 2017 04:00 #86140

  • milesdavis100
  • milesdavis100's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 19
  • Thank you received: 1
  • Karma: 0
Hi Again,

Finally getting a chance to get back into this -- I attempted deleting those files and it didn't work .. I get a read/write access error

However, on further investigation --

While my library has proper read/write access... I noticed that individual files and folders within the package have "CUSTOM" listed under "everyone" and "admin"

Now.. that seems like it could be the issue?

However, do you know of a way to change permissions for everything in a folder or do I have to go to every single file to change them?

Thanks! MD
The administrator has disabled public write access.

Can't Open Library , Permission Issue in use by local ?? 23 Mar 2017 23:28 #86694

  • milesdavis100
  • milesdavis100's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 19
  • Thank you received: 1
  • Karma: 0
Hello!

I wanted to update this thread I finally had a chance to work on this again and I figured it out !! The issue was, for some reasont he library from the Time Machin back-up was assigned strange permissions "Custom permissions" for files all scattered through the files . It was alot of work to do manually so I found.a program called BatCHMOD that was awesome, I ran it - and reset the permissions . The library loaded - finally!!

Thanks for your assistance. I wanted to leave this here for anyone else who might encounter this issue .

Thanks again !
The administrator has disabled public write access.

Can't Open Library , Permission Issue in use by local ?? 24 Mar 2017 09:42 #86699

  • FCPX.guru
  • FCPX.guru's Avatar
  • OFFLINE
  • Platinum Boarder
  • bbalser.com
  • Posts: 2462
  • Thank you received: 321
  • Karma: 32
BatChmod is awesome! Glad you got it fixed.
The administrator has disabled public write access.

Can't Open Library , Permission Issue in use by local ?? 24 Mar 2018 14:39 #94791

Ive got the same problem, I just tried downloading this app to but it didn't work, can you help?
This is what I'm getting....
“NEw Hardruve” is already in use by “harrybristow” on “harrys-imac-2.local”.
The administrator has disabled public write access.

Can't Open Library , Permission Issue in use by local ?? 11 Dec 2018 09:15 #98117

  • Sumari
  • Sumari's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 1
  • Karma: 0
BatchMod is what did it for me. I had the same issue, after upgrading to a 2018 MBP, even though my FCPX library was on the same external drive, I was getting that issue on the new Mac. BatchMod really cleaned it up. Interestingly, I had to unmount and move my external drive (where the library and all my FCP files are) and plug it back in on a different dongle, and that did the trick, after at first running BatchMod but getting no success. I'm finding that these dongles are all very finicky. I just got this MBP about 4 days ago and already purchased 4 dongles in an effort to get sh*t to work right. Some have good USB but slow ethernet, others have good ethernet but HDMI won't work - what a f...... nightmare!
OK rant over, good luck ya'll!
The administrator has disabled public write access.