Welcome, Guest
Username: Password: Remember me

TOPIC: Compressor Will Not Output Audio 48kHz

Compressor Will Not Output Audio 48kHz 27 Dec 2018 22:02 #98328

  • NTSC_TV
  • NTSC_TV's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 4
  • Karma: 0
recently updated to the latest Compressor version 4.4.3. It will not output any of my existing saved presets or new with 48kHz audio. Anyone else experience this? Any fix? I receive the following error message from FCPX (version 10.4.4): "The operation couldn’t be completed. (com.apple.Compressor.CompressorKit.ErrorDomain error -1.)"

Trying to output to any 48kHz I receive that message. It doesn't matter which preset I'm using. Yes, they are all custom and I've used them in the past on various projects, so they have worked. All my apps are up to date. One project is a 1080p 30 fps at 48kHz, another is a 1080p 29.97 fps at 48 kHz, which I then output to Compressor at that same sepc.

I just tried that 1080 29.97 fps 48 kHz and exported it at 1080p 60 fps 48 kHz and it worked fine... weird. But it wouldn't at 59.95, 30, or 29.97.

Using Hardware:
iMac (Retina 5K, 27-inch, Late 2014)
macOs Majave 10.14.2



What I've done so far:
1. Open Compressor by itself. Clear any and all batch jobs. Go to Preferences, to Advanced and click the Reset Queue button. Do a "Clear All Jobs" function. Click it again and do a "Repair Compressor" function. Reboot your Mac. I'd open Disk Utility and run a First Aid on all drives for safe measure.
2. Downloaded the free app "FCS Remover" and use it to totally remove Compressor from your system (custom presets should remain). www.digitalrebellion.com/fcsremover/ Then launch the App Store, click on your name at the bottom left, then scroll down to fine Compressor, and click the Install icon (cloud with a downward arrow). This will give you a fresh copy of the latest version.
The administrator has disabled public write access.

Compressor Will Not Output Audio 48kHz 05 Mar 2019 19:36 #99165

  • FCPX.guru
  • FCPX.guru's Avatar
  • OFFLINE
  • Platinum Boarder
  • bbalser.com
  • Posts: 2679
  • Thank you received: 350
  • Karma: 33
That is odd, because all my custom presets work. And 48kHz audio is standard. I hate to say you may have to configure those custom ones from scratch. I know this post is a few months old, but has there been any new discoveries about this?
The administrator has disabled public write access.

Compressor Will Not Output Audio 48kHz 05 Mar 2019 19:45 #99166

  • NTSC_TV
  • NTSC_TV's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 4
  • Karma: 0
I had to rebuild all the custom presets. Not really sure why, but it worked.
The administrator has disabled public write access.

Compressor Will Not Output Audio 48kHz 07 Mar 2019 00:18 #99187

  • FCPX.guru
  • FCPX.guru's Avatar
  • OFFLINE
  • Platinum Boarder
  • bbalser.com
  • Posts: 2679
  • Thank you received: 350
  • Karma: 33
Really odd, and a royal PITA. Sorry you hd to go through that.
The administrator has disabled public write access.